TeamDynamix Performance Degradation

Incident Report for Dartmouth College

Resolved

TeamDynamix has resolved the issue that was causing degraded performance in Work Management, and full service has been restored.
Posted Nov 11, 2025 - 08:32 EST

Update

TeamDynamix continues to work on developing a fix for the performance degradation. We'll continue to provide updates as we know more.
Posted Nov 10, 2025 - 16:57 EST

Update

TeamDynamix continues to work on developing a fix for the performance degradation. We'll continue to provide updates as we know more.
Posted Nov 10, 2025 - 14:39 EST

Identified

TeamDynamix has identified the issue and is actively working to develop a fix for the performance degradation. We'll continue to provide updates as we know more.
Posted Nov 10, 2025 - 11:38 EST

Investigating

TeamDynamix is investigating degraded performance. Affected applications include TDX ticketing applications, services, and knowledge bases/client portal applications. We will follow up as additional information is available from the vendor.
Posted Nov 10, 2025 - 10:27 EST
This incident affected: Academic Services and Administrative Services.