Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Dec 17, 2025 - 00:00 EST
Update
Updated list of affected locations.
On Wednesday December 17 between 12:01AM (Midnight) and 8:00 AM, ITC will be performing maintenance on network equipment serving the buildings listed below. During this time, interruptions to wired and wireless network service and phone service are expected. Services are expected to be restored by 8:00 AM.
1 Court St. (OSHER) 100 Whaleback Rd. 185 Dartmouth St.; Boston, MA 200 Lebanon St. (Trumbull Nelson) 23 E. Wheelock St. 30 S. Main St. 33 S. Main St. 48 Lyme Rd. 7 Lebanon St. Boston Investments Office (545 Boylston St.) Child Care Center College Storage Facility Dartmouth Sailing Club Boathouse (142 Shaker Blvd.) DOC House Gile Tract Facility Hanover Country Club Maintenance Building McKenzie Oil Facility Montgomery House Moosilauke Ravine Lodge Skiway Wilson Hall
Posted Dec 16, 2025 - 08:35 EST
Update
The maintenance work originally planned for Dec. 12 has now been rescheduled to Dec. 17.
Posted Dec 10, 2025 - 10:33 EST
Scheduled
On Friday December 12 between 12:01AM (Midnight) and 8:00 AM, ITC will be performing maintenance on network equipment serving the buildings listed below. During this time, interruptions to wired and wireless network service and phone service are expected. Services are expected to be restored by 8:00 AM.
200 Lebanon St. (Trumbull Nelson) 185 Dartmouth St.; Boston, MA Boston Investments Office (545 Boylston St.) Hanover Country Club Maintenance Building Montgomery House Moosilauke Ravine Lodge Skiway