Network Performance Degragation in Sudikoff Hall

Incident Report for Dartmouth College

Resolved

Everything is should be resolved. We will continue to monitor to ensure network performance.
Posted Aug 22, 2026 - 09:53 EDT

Investigating

We are investigating network issues detected in Sudikoff Hall. We will update as we learn more.
Posted Aug 22, 2026 - 08:51 EDT
This incident affected: Network.