GreenPrint Service Maintenance

Incident Report for Dartmouth College

Resolved

This incident has been resolved.
Posted Jun 10, 2026 - 18:09 EDT

Monitoring

The scheduled maintenance window has concluded. All systems have been restored and we are actively monitoring service health to ensure stability.
Posted Jun 10, 2026 - 10:12 EDT

Identified

The GreenPrint service will be unavailable during the planned maintenance window between 9am-10am on June 10.
Posted Jun 10, 2026 - 09:15 EDT