GitHub degraded performance

Incident Report for Dartmouth College

Resolved

GitHub has resolved the incident. If you are still experiencing issues with github.com then please submit a ticket through the Services Portal.
Posted Aug 17, 2026 - 22:25 EDT

Investigating

GitHub is investigating degraded performance. We will follow up as additional information is available from the vendor.
Posted Aug 17, 2026 - 11:33 EDT
This incident affected: Administrative Services.