Some users may encounter performance issues with Outlook

Incident Report for Dartmouth College

Resolved

Microsoft is reporting that the issue has been resolved.
Posted Oct 11, 2024 - 07:29 EDT

Monitoring

Users may notice Outlook using an increased amount of system resources, causing the client to freeze or crash. This issue affects all Outlook connection methods, including the desktop client and Outlook on the web.

This issue has been remediated; however, affected users will need to take action to apply the changes Microsoft has made to fix the problem:

- Outlook client and app users should restart their client or app to apply our changes. Outlook desktop client users may need to perform this action twice due to caching issues.

- Outlook on the web users should refresh their sessions. If that does not mitigate the issue, users are encouraged to clear their browser cache and refresh their Outlook on the web session.
Posted Oct 10, 2024 - 15:52 EDT
This incident affected: Email (M365 email).