Remote Desktop Services (RDS) - rds.dartmouth.edu

Incident Report for Dartmouth College

Resolved

Service has been restored and rds.dartmouth.edu is now operational.
Posted May 21, 2026 - 09:01 EDT

Investigating

rds.dartmouth.edu is down following monthly OS patching this morning. ITC is investigating. We will provide another update as more information becomes available
Posted May 21, 2026 - 08:47 EDT
This incident affected: Infrastructure (RDS Services).