Remote network instability

Incident Report for Dartmouth College

Resolved

Dartmouth has re-enabled this internet link and is not seeing signs of instability.
Posted May 15, 2025 - 14:27 EDT

Identified

ITC Network Services has shut down the unstable internet link as a mitigation, and traffic to/from campus is using other redundant connections. ITC Network Services is working with the affected internet provider to further resolve the issue.
Posted May 07, 2025 - 09:47 EDT

Investigating

One of Dartmouth's upstream internet providers is showing signs of instability, impacting traffic to campus from certain offsite locations. ITC Network Services is investigating and is implementing a mitigation.
Posted May 07, 2025 - 09:08 EDT
This incident affected: Network and Network - Buildings (Boston Investments Office (545 Boylston St.)).