Greenprint - driver issues

Incident Report for Dartmouth College

Resolved

ITC has identified and resolved the issue.

If you continue to experience issues. Please submit a ticket at services.dartmouth.edu or email help@dartmouth.edu
Posted Jun 27, 2025 - 12:23 EDT

Investigating

ITC is investigating a partial outage affecting the following Greenprint features: the Greenprint-PC driver and driver installation.

As a current workaround, please use Web Print, available at greenprint.dartmouth.edu.
Instructions can be found here: https://services.dartmouth.edu/TDClient/1806/Portal/KB/ArticleDet?ID=64906#4
Posted Jun 27, 2025 - 11:23 EDT
This incident affected: Academic Services.