Canvas Down

Incident Report for Dartmouth College

Resolved

This incident has been resolved.
Posted May 08, 2026 - 09:22 EDT

Investigating

Canvas is currently experiencing an outage. Dartmouth is monitoring and will update when there is information on restoration of service.
Posted May 07, 2026 - 16:39 EDT
This incident affected: Academic Services.