Advance is not available

Incident Report for Dartmouth College

Resolved

Advance is now functioning normally.
Posted Sep 20, 2023 - 14:37 EDT

Investigating

The production Advance application is not available. We are investigating.
Posted Sep 20, 2023 - 13:57 EDT
This incident affected: Administrative Services.