OnBase Unity Client and Eforms are all down. We are investigating

Incident Report for Dartmouth College

Resolved

OnBase eforms and Unity client is back to normal and working as expected.
Posted May 26, 2026 - 08:12 EDT

Investigating

OnBase Unity Client and Eforms are all down. We are investigating.
Posted May 26, 2026 - 08:03 EDT
This incident affected: Administrative Services.