SecureW2/JoinNow Maintenance

Scheduled for Apr 6, 00:30 - 06:30 EDT

Update

This maintenance has been rescheduled for Sunday, April 6.
Posted Mar 28, 2025 - 19:25 EDT

Scheduled

SecureW2 has announced an upcoming scheduled maintenance window for the JoinNow software - the software used to enroll devices for connection to the eduroam Wi-Fi network. Enrollment of new devices using JoinNow may be unsuccessful during this time. Devices that are already enrolled will not be affected.
Posted Mar 18, 2025 - 10:11 EDT
This scheduled maintenance affects: Network.