No further issues have been observed. If you are still experiencing network connectivity or reachability issues, please contact the ITC Service desk at services.dartmouth.edu .
Posted Mar 19, 2026 - 15:39 EDT
Monitoring
The roll-back has been completed. Network Services is continuing to verify services are operational. If you are still experiencing connectivity issues at this time, please report those issues via the ITC Services Portal at services.dartmouth.edu.
Posted Mar 19, 2026 - 10:33 EDT
Update
The roll-back work is beginning now.
Posted Mar 19, 2026 - 10:00 EDT
Update
Network Services will be beginning the roll-back at 10:00 AM. During this roll-back, an interruption of network connectivity up to 5 minutes is expected.
Posted Mar 19, 2026 - 09:30 EDT
Identified
Following network firewall changes on the morning of March 18, there have been multiple reports of intermittent trouble accessing websites, applications, and other systems. Network Services is preparing to roll-back the firewall changes to their prior state to resolve these issues. This roll-back is expected to be completed this morning. During this roll-back, an interruption of network connectivity up to 5 minutes is expected. We will provide notice of the time of this expected interruption 30 minutes prior to it occurring. Please check the ITC Status Page at status.dartmouth.edu for this notice and for further updates.