Intermittent Login Issues

Incident Report for Dartmouth College

Resolved

ITC has resolved the incident. If you are still experiencing issues with authentication then please submit a ticket through the Services Portal.
Posted Aug 18, 2026 - 11:48 EDT

Identified

ITC is investigating issues that are preventing some applications from loading. We will provide another update as more information becomes available.
Posted Aug 18, 2026 - 09:47 EDT

Monitoring

A fix has been applied and all systems are performing as expected. We're continuing to monitor for any recurring problems.
Posted Aug 18, 2026 - 08:37 EDT

Update

We are continuing to work on a fix for this issue.
Posted Aug 18, 2026 - 07:49 EDT

Identified

ITC has identified the issue affecting authentication and is working to restore service. We will continue to provide updates here.
Posted Aug 18, 2026 - 07:07 EDT

Investigating

ITC is investigating degraded performance with authentication. We will provide another update as more information becomes available.
Posted Aug 18, 2026 - 06:30 EDT
This incident affected: Authentication.