SharePoint/OneDrive Delays

Incident Report for Dartmouth College

Resolved

This incident has been resolved.
Posted Jan 29, 2025 - 16:49 EST

Update

Microsoft is now reporting issues accessing all Microsoft 365 services. The scope of the issue has not yet been determined, but some M365 pages may not load.
Posted Jan 29, 2025 - 13:40 EST

Investigating

Microsoft has reported an issue affecting OneDrive and SharePoint Online. Users may experience intermittent delays or navigation errors when accessing OneDrive and SharePoint content. We will provide updates as necessary.
Posted Jan 29, 2025 - 11:21 EST
This incident affected: Email (M365 email).