TDX Email Notifications Delayed or not Delivered

Incident Report for Dartmouth College

Resolved

This incident has been resolved.
Posted Sep 21, 2026 - 11:00 EDT

Monitoring

We're aware of an issue affecting outgoing email from TeamDynamix (TDX). Some notifications, including ticket confirmations and updates, may be delayed or not delivered. Tickets and other TDX functions are working normally, and you can still submit and view requests in TDX directly.
Posted Sep 18, 2026 - 21:04 EDT
This incident affected: Email (M365 email).