Exchange Online Connection Issues
Incident Report for Dartmouth College
Resolved
This incident has been resolved.
Posted Jul 26, 2024 - 07:26 EDT
Investigating
Microsoft has reported an issue affecting Exchange Online. Users in North America may be unable to access Exchange services through multiple connection methods, including Outlook on the Web. We will post an update when more information is available.
Posted Jul 25, 2024 - 16:06 EDT
This incident affected: Email (M365 email).