McCulloch Partial Network Outage

Incident Report for Dartmouth College

Resolved

Services are restored.
Posted Dec 16, 2025 - 07:34 EST

Identified

The network outage is caused by planned electrical maintenance. Services will be restored once power returns.
Posted Dec 16, 2025 - 07:01 EST

Investigating

Due to a power failure, network services in some parts of McCulloch are unavailable. ITC is investigating.
Posted Dec 16, 2025 - 06:32 EST
This incident affected: Network and Network - Buildings (McCulloch Dormitory).