Planon

Incident Report for Dartmouth College

Resolved

Deleting this Status Page notification is it was a duplicate.
Posted Mar 09, 2026 - 09:42 EDT

Investigating

CSTS is investigating a reported outage with Planon. Users are currently unable to log in to the application. We will provide another update as more information becomes available.
Posted Mar 09, 2026 - 09:28 EDT
This incident affected: Administrative Services.