Fayerweather Hall Network Outage

Incident Report for Dartmouth College

Resolved

Outage was caused by an electrical issue. Network has been restored to Fayerweather Hall.
Posted Aug 07, 2026 - 12:34 EDT

Investigating

There is a network outage at Fayerweather Hall. We are currently investigating the issue.
Posted Aug 07, 2026 - 11:19 EDT
This incident affected: Network - Buildings (Fayerweather Hall Mid, Fayerweather Hall North, Fayerweather Hall South).