Dartmouth Chat March 2026 release maintenance extended

Incident Report for Dartmouth College

Resolved

This incident has been resolved.
Posted Mar 19, 2026 - 08:37 EDT

Investigating

Upgrade of Dartmouth Chat for the March 2026 release is still ongoing.

Expected completion time is 9:00AM
Posted Mar 19, 2026 - 07:37 EDT
This incident affected: Research Computing (AI).