Maintenance on Zoom has completed. To manually update your app, open the Zoom client, click on your profile in the upper right of the application window, and from the drop-down menu choose Check for Updates. For questions or assistance, please submit a ticket at http://services.dartmouth.edu/.
Posted Feb 02, 2024 - 07:58 EST
In progress
Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Feb 01, 2024 - 17:01 EST
Scheduled
At 5 pm on February 1st, Dartmouth will be updating the minimum version required on all Zoom clients. This update ensures that our community has the latest privacy and security updates. After 5 pm on the 1st anyone attempting to sign in or join a meeting will be prompted to update the Zoom client to the current minimum version.
Posted Jan 29, 2024 - 16:07 EST
This scheduled maintenance affected: Academic Services and Administrative Services.