Sign-on Services Outage

Incident Report for Dartmouth College

Resolved

The sign-in system has been restored. Any applications or services that depend on Dartmouth sign-in, including GlobalProtect, are now accessible.
Posted Apr 12, 2026 - 10:22 EDT

Investigating

Dartmouth sign-on services are unavailable due to complications from the data center power outage early this morning. ITC is actively working on restoring service.
Posted Apr 12, 2026 - 09:33 EDT
This incident affected: Administrative Services.