ITC Investigating Wide range of application outages

Incident Report for Dartmouth College

Resolved

Applications outage been resolved and Infrastructure is monitoring.
Posted Apr 13, 2026 - 06:59 EDT

Update

Applications and services are being restored following the power outage at the Dartmouth data center this morning. Please reach out to ITC if you encounter an app or service that is still unavailable.
Posted Apr 12, 2026 - 11:25 EDT

Monitoring

The issue was related to a wide spread power outage effecting Dartmouth Data Centers. Once power was restored ITC was able to bring systems back online. We will continue to monitor the health of systems overnight. Thank you.
Posted Apr 12, 2026 - 11:24 EDT

Update

Power outage at datac center has caused the outage of applications,
ITC is working with FO&M to restore power
Posted Apr 12, 2026 - 07:39 EDT

Investigating

ITC is investigating reports of application outages
Posted Apr 12, 2026 - 06:41 EDT
This incident affected: Network.