Partial Network Outage BMR Datacenter

Incident Report for Dartmouth College

Resolved

The failed hardware has been replaced and affected BMR datacenter network connections are back online.
Posted Aug 26, 2026 - 14:25 EDT

Identified

We are working with the equipment vendor to replace the failed hardware.
Posted Aug 25, 2026 - 12:03 EDT

Investigating

ITC is investigating an equipment failure affecting some network connections in the BMR datacenter.
Posted Aug 25, 2026 - 11:01 EDT
This incident affected: Network.