Campus Wide Internet Outage
Incident Report for Dartmouth College
Resolved
The campus internet network is now operational.
Posted May 31, 2024 - 10:05 EDT
Monitoring
ITC has identified the issue affecting the Internet Network and service appears to be restored. We are currently monitoring the situation to ensure stability. We will continue to provide updates here.
Posted May 30, 2024 - 16:04 EDT
Investigating
ITC is investigating a major outage with the Internet Network. Affected applications include all devices that use the internet for connectivity and services. ITC Network Service is actively investigating the issue. We will provide another update as more information becomes available.
Posted May 30, 2024 - 15:54 EDT
This incident affected: Network.