Appworx PROD issues

Incident Report for Dartmouth College

Resolved

ITC has resolved the incident. If you are still experiencing issues with [name of component] then please submit a ticket through the Services Portal.
Posted Jan 23, 2024 - 08:55 EST

Investigating

We are experiencing some issues with Appworx PROD and are investigating.
Posted Jan 23, 2024 - 08:28 EST
This incident affected: Academic Services.