Password change failures

Incident Report for Dartmouth College

Resolved

The problem has been resolved
Posted Sep 14, 2026 - 14:21 EDT

Investigating

Password changes/resets using myaccount.dartmouth.edu and helpdash.dartmouth.edu are currently failing. We are investigating the issue
Posted Sep 14, 2026 - 14:05 EDT
This incident affected: Authentication.