35 N Main St Network Down

Incident Report for Dartmouth College

Resolved

Network has been restored to 35 N Main
Posted Jul 21, 2026 - 15:33 EDT

Identified

All network is currently down in 35 N Main st due to failure of fiber to the building. Contractors are currently working on repairs to bring building back online
Posted Jul 21, 2026 - 12:16 EDT
This incident affected: Network.