OnBase Performance Issues

Incident Report for Dartmouth College

Monitoring

ITC staff have implemented a fix and will continue monitoring.
Posted Apr 01, 2025 - 14:07 EDT

Investigating

ITC is investigating degraded performance with OnBase. Affected applications include OnBase Unity Client. We will provide another update as more information becomes available.
Posted Mar 31, 2025 - 15:06 EDT
This incident affects: Administrative Services.