Update: We have identified that rebooting access points (APs) resolves the connectivity issue. ITC Network Services is now rebooting APs selectively across the affected buildings to restore service while minimizing downtime.
Affected buildings:
Visual Arts Center (VAC) 7 Lebanon St McKenzie Lodge 15 Webster Ave Hitchcock Silsby/Rockefeller
We will continue to post updates here as service is restored in each building.
We apologize for the inconvenience and appreciate your patience.
Posted Sep 22, 2026 - 11:41 EDT
Identified
We are currently experiencing WiFi connectivity issues affecting the following buildings:
Visual Arts Center (VAC) 7 Lebanon St McKenzie Lodge 15 Webster Ave Hitchcock Silsby/Rockefeller
ITC Network Services is actively investigating the issue and working to restore service. We will post updates here as more information becomes available.
We apologize for the inconvenience and appreciate your patience.
Posted Sep 22, 2026 - 10:47 EDT
This incident affects: Network - Buildings (7 Lebanon St., The Lodge, McKenzie Hall, Rockefeller Center and Silsby Hall, Visual Arts Center, 15 Webster Ave. (Epsilon Kappa Theta)).