Jenkins jobs failing due to GitHub degraded performance

Incident Report for Dartmouth College

Resolved

GitHub has resolved their outage. Jenkins jobs and other services that rely on GitHub are seeing restored functionality.
Posted Mar 03, 2026 - 15:04 EST

Investigating

Jenkins jobs have been failing since about 2pm due to a GitHub service outage. GitHub outage information can be found here: https://www.githubstatus.com/
Jenkins functionality will be restored once the upstream problems at GitHub are resolved.
Posted Mar 03, 2026 - 14:47 EST
This incident affected: Administrative Services.