GoToConnect Connectivity Issues

Incident Report for Dartmouth College

Resolved

The connectivity-related issues with GoToConnect are resolved. Our phone vendor (GoTo) have confirmed that service is operational. They will be actively monitoring the progress of this event and will be on alert if anything should arise.
Posted Jan 30, 2024 - 11:13 EST

Investigating

GoToConnect is currently investigating connectivity-related issues. Affected applications may experience degraded performance or connectivity interruptions. ITC is keeping track with GoToConnects NOC and Development team updates to resolve the issue.
Posted Jan 30, 2024 - 10:13 EST
This incident affected: Telephone.