RESOLVED: Agiloft is Currently Unavailable

Incident Report for Dartmouth College

Resolved

This incident has been resolved.
Posted Jan 12, 2026 - 15:40 EST

Update

This issue has been resolved.
Posted Jan 12, 2026 - 15:40 EST

Investigating

The Agiloft System that manages the Procurement Contract Management System and Financial Systems Access is currently unavailable. Agiloft is investigating the incident.
Posted Jan 12, 2026 - 14:38 EST
This incident affected: Administrative Services.