TouchNet

Incident Report for Dartmouth College

Resolved

TouchNet maintenance has completed.
Posted Mar 28, 2025 - 07:20 EDT

Monitoring

TouchNet is undergoing maintenance. We are monitoring the site and will post a notification when TouchNet becomes available.
Posted Mar 28, 2025 - 03:52 EDT
This incident affected: Academic Services.