ITC has completed the upgrade to the CAS Authentication system. Some users may need to re-authenticate, and the visual appearance of the login page has changed.
See this KBA for more information.
If you have trouble logging in, you might want to:
- Go to - logout.dartmouth.edu - Close the browser window - Log-in again
Posted Mar 25, 2025 - 07:27 EDT
Verifying
ITC has completed the upgrade to the CAS Authentication system. Some users may need to re-authenticate, and the visual appearance of the login page has changed.
See this KBA for more information.
If you have trouble logging in, you might want to:
-Go to - logout.dartmouth.edu -Close the browser window -Log-in again
Posted Mar 25, 2025 - 05:59 EDT
In progress
ITC is beginning the upgrade to the CAS Authentication system now. The system is expected to remain functional during the upgrade, but some users may need to re-authenticate when it is complete.
Posted Mar 25, 2025 - 05:33 EDT
Scheduled
Dartmouth's Authentication system will be updated, changing the visual appearance of the login screen.