Tuck - Sysaid Outage

Incident Report for Dartmouth College

Resolved

This incident has been resolved.
Posted May 12, 2025 - 10:35 EDT

Investigating

We are experiencing a temporary outage of the IT ticketing system and are working to have this service restored. In the meantime, for IT or AV assistance please reach out to helpdesk@tuck.dartmouth.edu or call 603-646-1818. Updates to follow.
Posted May 12, 2025 - 09:25 EDT