Murdough network partially down

Incident Report for Dartmouth College

Resolved

This incident has been resolved.
Posted Apr 11, 2026 - 20:25 EDT

Identified

The issue has been identified and a fix is being implemented.
Posted Apr 11, 2026 - 19:36 EDT

Investigating

We are currently investigating this network issue, network might be down temporarily for a few minutes.
Posted Apr 11, 2026 - 18:22 EDT
This incident affected: Network - Buildings (Murdough Center).