Google Workspace Storage Alert
Incident Report for Dartmouth College
Resolved
This incident has been resolved.
Posted Nov 14, 2024 - 16:03 EST
Update
We are continuing to investigate this issue.
Posted Nov 14, 2024 - 16:03 EST
Investigating
Some users may see a banner in Google Workspace (Share Drives) indicating "Organization storage low … 14% left of your 1.03 PB Google Workspace storage." This warning is appearing intermittently but is not affecting normal usage at this time.

The ITC team is aware of the storage notification and is actively monitoring and managing our Google Workspace storage allocation to ensure continued service. There is no immediate impact on access or functionality. We are working closely with Google to ensure additional storage needs are addressed proactively.

No action is needed on your part, and we will keep the community updated if any changes occur. Thank you for your understanding.
Posted Nov 12, 2024 - 08:00 EST
This incident affected: Administrative Services.