Dartmouth emails to external recipients are failing

Incident Report for Dartmouth College

Resolved

The issue has been resolve by Microsoft and we are currently moving to a monitoring mode to ensure there are no further issues.
Posted Sep 16, 2026 - 23:15 EDT

Update

We have temporarily disabled Listserv capabilities to reduce the number of external emails that are being sent as we work through this issue.
Posted Sep 16, 2026 - 22:03 EDT

Identified

We have identified an issue where Dartmouth users sending emails to external recipients are failing. The emails bounce back with an error message. We are opening a ticket with Microsoft and continuing to investigate a resolution.
Posted Sep 16, 2026 - 20:26 EDT
This incident affected: Email (M365 email).