Exchange On-Premises Delivery Issues

Incident Report for Dartmouth College

Resolved

This incident has been resolved.
Posted Aug 14, 2025 - 13:45 EDT

Monitoring

We've verified that the issue has been resolved and mail should be flowing normally again. We will continue to monitor for more issues.
Posted Aug 14, 2025 - 12:48 EDT

Identified

ITC has identified an issue affecting one of the on-premises Exchange servers that caused email to be delayed. We've put a temporary workaround in place and are working to resolve the issue.
Posted Aug 14, 2025 - 12:18 EDT
This incident affected: Email (M365 email).