GreenPrint Down
Incident Report for Dartmouth College
Resolved
GreenPrint services have been restored.
Posted Jul 23, 2024 - 11:06 EDT
Investigating
We are currently investigating and working with our vendor about issues with GreenPrint (Student Printing)
Posted Jul 22, 2024 - 18:05 EDT
This incident affected: Academic Services.