Tuck Printer Issues

Incident Report for Dartmouth College

Resolved

This incident has been resolved.
Posted 15 days ago. Mar 25, 2025 - 08:16 EDT

Monitoring

We have identified that a recent update to our print drivers was the cause of the morning issues, we have rolled back the drivers. We will monitor through out the day
Posted 16 days ago. Mar 24, 2025 - 09:40 EDT

Update

We are continuing to investigate this issue.
Posted 16 days ago. Mar 24, 2025 - 09:16 EDT

Investigating

Tuck Print at Tuck is having issues, and we are investigating. This can affect printing staff and students.
Posted 16 days ago. Mar 24, 2025 - 09:12 EDT
This incident affected: Academic Services and Administrative Services.