Power has been stable across campus, and network connectivity has returned to normal operations.
Posted Apr 29, 2025 - 10:13 EDT
Monitoring
Power is restored on campus. Network equipment are coming back up and we will continue to monitor for any network related outages across campus.
Posted Apr 28, 2025 - 12:54 EDT
Update
See the email to campus from Facilities.Center@dartmouth.edu for more information on campus power outage, which includes the following: "Liberty Utilities and National Grid are working on identifying and correcting the issue and will be restoring service as soon as possible. Presently, there is no estimated time of power restoration."
Posted Apr 28, 2025 - 12:18 EDT
Update
Regarding the campus power outage and networking effect:
Dartmouth Network Service equipment has UPS battery backup to keep our networking online through short power outages, including Wi-Fi, wired Ethernet, and VOIP phones. Different locations will last without power for different lengths of time before the UPS battery runs out and the equipment shuts down, so we expect additional networking to fall offline as the power outage continues.
When power is restored, network equipment is expected automatically recover within 15-30 minutes. Network Services will continue to monitor the situation and make sure equipment comes back online when power is restored.
From what Network Services is aware, the current ETA for power being restored is 2pm.
Posted Apr 28, 2025 - 11:51 EDT
Identified
Theres a campus wide power outage affecting the network. We will provide updates as we learn more.