GitHub - degraded UI performance

Incident Report for Dartmouth College

Resolved

GitHub has resolved the incident. If you are still experiencing issues then please submit a ticket through the Services Portal.
Posted Feb 09, 2026 - 18:29 EST

Identified

GitHub is working on investigating reports of degraded performance
Posted Feb 09, 2026 - 11:35 EST
This incident affected: Web.