Sudikoff Network Outage

Incident Report for Dartmouth College

Resolved

Services were restored as of 9:00PM.
Posted May 07, 2026 - 06:41 EDT

Identified

ITC is investigating a network equipment failure affecting Sudikoff.
Posted May 06, 2026 - 20:05 EDT
This incident affected: Network and Network - Buildings (Sudikoff Lab).