Wi-Fi Connection Failures

Incident Report for Dartmouth College

Resolved

No further issues have been observed.
Posted Apr 24, 2026 - 14:08 EDT

Monitoring

All services have been restored and no equipment appears to remain affected. ITC is continuing to monitor service health.
Posted Apr 23, 2026 - 16:00 EDT

Identified

The issue has been identified and services are in the process of being restored.
Posted Apr 23, 2026 - 15:28 EDT

Investigating

ITC is investigating Wi-Fi connection failures affecting some areas of various campus buildings.
Posted Apr 23, 2026 - 13:39 EDT
This incident affected: Network.