Microsoft 365 License Disruption

Incident Report for Dartmouth College

Resolved

After continued monitoring, we’ve confirmed that the licensing issue has been resolved. As a result of the issue, some mailboxes lost previously assigned Full Access delegate permissions. If you are still missing access to a shared mailbox, please submit a support ticket to request restoration of those permissions.
Posted Jun 27, 2025 - 10:28 EDT

Identified

ITC identified an issue where some user accounts temporarily lost access to certain licensed services in Microsoft 365 due to a configuration change. The underlying cause has been addressed, and license assignments have been restored. We are continuing to monitor the situation to ensure full resolution. If you continue to encounter problems accessing services, please contact the Service Desk.
Posted Jun 26, 2025 - 12:24 EDT
This incident affected: Email (M365 email).