Listserv Down

Incident Report for Dartmouth College

Resolved

This incident has been resolved.
Posted Aug 12, 2025 - 08:08 EDT

Identified

We have applied a temporary measure to mitigate the ongoing LISTSERV issue. As a result, some users may have limited access to the service. We are working to restore full access as quickly as possible and will provide updates as the situation progresses.
Posted Aug 08, 2025 - 19:35 EDT

Investigating

ITC has identified an issue with LISTSERV (listserv.dartmouth.edu) that is currently affecting access to the website. We are investigating the cause and working to restore services. We will provide updates as more information becomes available.
Posted Aug 08, 2025 - 17:42 EDT
This incident affected: Email (M365 email) and Infrastructure (Computing Infrastructure).